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1 Introduction 

The TMD2755 evaluation kit comes with everything needed to evaluate the TMD2755. The device 

features proximity detection and digital ambient light sensing (ALS). 

1.1 Kit Contents 

Figure 1:  

Evaluation Kit Contents 

 

 

No. Item Description 

1 TMD2755 Daughter Card PCB with TMD2755 sensor installed 

2 EVM Controller Board Used to communicate USB to I2C  

3 USB Cable (A to Mini-B) Connects EVM controller to PC 

4 Flash Drive Include application installer and documents 

 

1.2 Ordering Information 

 

Ordering Code Description 

TMD2755 EVM TMD2755 ALS and Proximity Sensor Module   
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2 Getting Started 

The software should be installed prior to connecting any hardware to the computer. Follow the 

instructions found in the Quick Start Guide (QSG). This loads the required driver for the USB interface 

and the device’s graphical user interface (GUI).  

The balance of this document identifies and describes the controls available on the GUI. In 

combination with the TMD2755 datasheet, the QSG and application notes available on the ams 

website, www.ams.com, there should be enough information to allow evaluation of the TMD2755 

device. 
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3 Hardware Description 

The hardware consists of the EVM Controller, the TMD2755 EVM daughter card, and a USB interface 

cable. The EVM controller board provides power and I2C communication to the daughter card through 

a seven-pin connector. When the EVM controller is connected to the PC through USB, a green LED 

on the board flashes once on power up to indicate the system is getting power. 

For schematics, layout and BOM information please see the documents included with the install 

located in the TMD2755 EVM folder (All Programs -> ams -> TMD2755 EVM -> Documents).  

Figure 2:  

Evaluation Kit Hardware 
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4 Software Description 

The main window (Figure 3) contains the system menus, system level controls, device information and 

logging status. The ALS tab contains controls for the light sensing function and the Prox tab contains 

settings for the proximity function. The application polls the ALS and proximity raw data continuously 

and calculates the Lux values and prox standard deviation values.  

Figure 3:  

GUI Main Window 

 

 

4.1 Connect Software to Hardware 

On startup, the software automatically connects to the hardware. On successful initialization, the 

software displays a main window, containing controls pertinent to the connected device. If the software 

detects an error, an error window appears. If “Device not found or is unsupported” appears, verify the 

correct daughterboard is properly connected to the EVM controller board. If “Cannot connect to EVM 

board” appears, verify the USB cable is connected. When the EVM controller board is connected to 

the USB, a green LED on the board flashes once on power up to indicate the USB cable is connected 

and providing power to the system. 
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If the EVM board disconnects from the USB bus while the program is running, it displays an error 

message and then terminates.  Reconnect the EVM board and restart the program. 

4.2 System Menus 

At the top of the window there are pull-down menus labeled “File”, “Log”, and “Help”. The File menu 

provides basic application-level control. The Log menu controls the logging function, and the Help 

menu provides version and copyright information for the application. 

4.2.1 File Menu 

The File menu contains the following functions: 

Figure 4:  

File Menu 

 

 

The Reread Registers function forces the program to re-read all of the control registers from the 

device and display them on the screen. This does not read the output data, because the program 

reads those registers continually while it is running. 

The Lux Coefficients menu allows the user to Display, Load or Save the lux coefficients used to 

calculate lux. See ALS Lux Coefficients section for more details.  

Click on the Exit command to close the main window and terminate the application. Any unsaved log 

data is cleared from memory. The application can also be close by clicking the red “X” in the upper 

right hand corner. 

4.2.2 Log Menu 

The Log menu controls the logging function and saves the log data to a file. Log data accumulates in 

memory until discarded or written to a data file. 
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Figure 5:  

Log Menu 

 

 

Click Start Logging to start the logging function. Each time the program polls the output information 

from the device, it creates a new log entry showing the raw data values, the values of various control 

registers, and the values entered by the user into the text fields near the bottom right corner of the 

window. 

Click Stop Logging to stop the logging function. Once logging stops, the user may store the data in a 

file, or continue collecting additional data by clicking Start Logging again. 

The Log a Single Entry command causes logging to start, collect one single entry, and immediately 

stop again. This function is not available when logging is already running. 

Click Clear Log to discard any previously collected data. If there is data in memory, which has not 

been saved to disk, this function displays a prompt asking to verify it is OK to discard the data. If the 

log is active when this function executes, the log continues running after the existing data is discarded. 

Click Save Log to save the collected log data to a csv file. This stops the logging function, if it is 

active, and displays a file dialog box to specify where to store the logged data. The Log Status and 

Control Information section below describes the default file name, but you may change the file name if 

desired. 

4.2.3 Help Menu 

The Help menu contains a single function: About. 

Figure 6:  

Help Menu 

 

 

The About function displays a dialog box (Figure 7) showing the version and copyright information for 

the application and library. Click the OK button to close this window and continue. 
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Figure 7:  

About Window 

 

 

4.3 System Level Controls 

Immediately below the top menu bar there are checkboxes used to control the system level functions 

of the TMD2755 device.  

The Power On checkbox controls the PON function of the TMD2755. When this box is checked, the 

power is on and the device can operate. When this box is unchecked, the power is off and the device 

does not operate (You can still change the control registers, but the device does not perform ALS and 

Prox functions). 

The ALS Enable checkbox controls the AEN function of the TMD2755. When this box is checked, the 

device collects and report ALS data as programmed. When this box is unchecked, the ALS function 

does not operate. 

The Prox Enable checkbox controls the PEN function of the TMD2755. Proximity detection is enabled 

when this box is checked or disabled when unchecked.  

4.4 Auto Polling 

The application automatically polls the TMD2755 raw data of ALS and Prox if enabled. The Poll 

Interval displays the time between reads of the device. 
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4.5 Device ID Information 

The lower left corner of the window displays the ID number of the EVM Controller board, identifies the 

device being used and displays the ID of the device. 

4.6 Log Status and Control Information 

The lower right corner of the window contains status information and controls for the logging function: 

Figure 8:  

Logging Status 

 

 

This section contains text boxes that are stored in the log file data and used to build the file name for 

the log file. If the data in these fields are changed, the new values are stored with any new data 

logged. The default file name is based on these values at the time the log file is written. If nothing is 

entered in these boxes they default to a period (“.”). 

Sample default file name: 

TMD2755_1-2-3_Log_HH_MM_SS.csv 

  From Application 

  From User Input 

The Count value displayed is a count of the number of samples currently in the log buffer. 

The Elapsed Time value indicates the elapsed time since data logging started. 

The numeric box in the bottom right-hand corner sets a limit to the size of the collected dataset. You 

may select a value from the pull-down list, or enter a value manually.  When the number of entries in 

the log reaches this value, the program will automatically stop logging and display a file dialog box to 

specify where to store the logged data. You may change the file name if desired.  The maximum value 

that may be entered in this field is 32000. 
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4.7 “ALS” Tab 

The main portion of the screen contains a tab labeled ALS. The controls in this tab are divided into 3 

sections, each performing a separate function. 

Figure 9 :  

ALS Tab 

 

 

4.7.1 ALS Controls 

The left side of the ALS tab contains controls to set various ALS settings. 

The ATIME control sets the time of the ALS integration. ATIME can be adjusted in 2.778ms steps. 

The AGAIN control is a pulldown menu which sets the analog gain of the ALS sensor. The values 

available are 128x and 1024x.  

The AWEN checkbox controls the ALS Wait feature.  When this box is checked, the values for WTIME 

and WLONG determine the time between ALS cycles. When this box is unchecked, there is no wait 

period between ALS cycles and the values of AWTIME and AWLONG are ignored. 

The AWTIME control sets the time to wait between ALS cycles. AWTIME can be adjusted in 2.778ms 

steps. 

The AWLONG checkbox controls the AWTIME factor.  When this box is checked, the wait time 

between ALS cycles increases by a factor of 12x. 
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4.7.2 ALS Lux Coefficients 

The TMD2755 supplies information that is used to calculate Lux (unit of illumination). The Lux 

equation for the TMD2755 uses a combination of data from the sensor and various coefficients to 

calculate the Lux value. The software is pre-configured with coefficients for an open-air configuration. 

When the sensor is placed behind glass, different coefficients should be loaded into the software to 

update the Lux equation. The coefficients can be loaded or saved to an XML file using the File menu. 

To ensure the proper XML format first save the current coefficients using File > Lux Coefficients > 

Save. Once the file is saved, locate the XML file created and edit with a text editor such as notepad to 

change the coefficients. Then go to File > Lux Coefficients > Load and select the XML file that was 

updated.  

The software can also automatically load new coefficients upon starting the GUI. To do this save the 

XML file as TMD2755_luxeq.xml in the system documents directory 

(%USERPROFILE%\Documents, also known as My Documents). Then restart the GUI and see a 

dialog appear with the new coefficients displayed. 

If you are experiencing trouble loading new coefficients, this may indicate a problem with the file 

format. The XML file must contain all the required Lux equation elements to be loaded. The format of 

the file follows the standard XML format and is as follows: 

<?xml version="1.0" encoding="utf-8"?> 

<!-- Device:TMD2755 Saved:5/11/2020 1:55:32 PM --> 

<luxeq> 

  <eq_values> 

    <coef name="DGF" value="123" /> 

    <coef name="CoefB" value="1.427" /> 

    <coef name="CoefC" value="0.849" /> 

    <coef name="CoefD" value="0.834" /> 

  </eq_values> 

</luxeq> 

4.7.3 ALS Output Data 

The top right corner of the ALS tab displays the output data. This data is continuously read. The 

polling interval is shown above the tab.  

● ALS displays the Visible Light Channel data count. 

● IR displays the IR Channel data count. 

● Lux displays the calculated lux. 

4.7.4 ALS Data Plot 

The remaining portion of the ALS tab is used to display a running plot of the collected ALS values and 

calculated Lux. The last 350 values are collected and plotted on the graph. As additional values are 
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added, the old values will be deleted from the left side of the graph. To start the plotting function, 

check the Enable Plot checkbox and select the ALS, IR, or Lux checkboxes. 

Figure 10:  

ALS Data Plot 

 

 

The scale of the Y-axis of the plot can be adjusted by clicking on the small up and down arrows at the 

top left corner of the plot. The scale can be set to any power of 2 from 64 through 65536. 

Click the Clear Plot button to discard the current data and continue plotting the new data. Note if the 

Clear Plot button is clicked while the plot is disabled, the data is discarded, but the actual plot will not 

be updated until the plot function is re-enabled. 

4.8 “Prox” Tab 

The main portion of the screen contains a tab labeled Prox. The controls in this tab are divided into 3 

sections, each performing a separate function. 
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Figure 11 :  

Prox Tab 

 

 

4.8.1 Prox Controls 

The left side of the Prox tab contains controls to set various Prox settings. 

The PPULSE controls the number of pulses used for each prox cycle. The number of pulses is one 

more than the PULSE value and is displayed immediately to the right of the box. 

The PPULSE_LEN control sets the width of all IR LED pulses within the proximity cycle. Longer 

pulses result in increased proximity range and typically result in less electrical noise generated in the 

analog front end. 

The PGAIN1 and PGAIN2 controls is are pulldown menus that lets you control the two gain stages of 

the proximity IR sensor. The PGAIN1 values are 1x, 2x, 4x and 8x. The PGAIN2 values are 2.5x, 5x 

and 10x. 

The PLDRIVE control sets the drive strength of the IR LED current. The values range 7mA to 10mA. 

PRATE controls sets the duration of a single prox sample. The time is equal to (PRATE + 1) * 88µs. 

The time, in microseconds, is displayed immediately to the right of this control. 

The PWEN checkbox controls the Prox Wait feature.  When this box is checked, the values for 

PWTIME and PWLONG determine the time between Prox cycles. When this box is unchecked, there 

is no wait period between Prox cycles and the values of PWTIME and PWLONG are ignored. 
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The PWTIME control sets the time to wait between prox cycles. PWTIME can be adjusted in 2.778ms 

steps. 

The PWLONG checkbox controls the PWTIME factor.  When this box is checked, the wait time 

between Prox cycles increases by a factor of 12x. 

The Offset Range Extension functionality has two controls.  The Enable checkbox, turns the 

functionality on and off. The numeric control in this box sets the number of extension steps from 

Nominal to Nominal + 31 Steps. 

The Binsrch Target control sets the target value for the Proximity offset calibration function. 

The POFFSET controls shift PDATA to remove crosstalk from the proximity data. The values range 

from -255 to 255.  This value can be set manually, or it can be set by the Proximity offset calibration. 

The Cal button triggers the sensor’s proximity offset calibration sequence. This function automatically 

selects a POFFSET to remove crosstalk from PDATA. 

The Auto Offset Adjust checkbox enables the function that automatically decrements the POFFSET 

value any time the PDATA value is 0.  When this function is active, manual changes to the POFFSET 

control are disabled, and the program will read and update the POFFSET value each time it reads the 

PDATA value. 

The Auto Pulse Control function can be turned off with the Disable checkbox. This feature is used 

for hardware configurations with high crosstalk. When Auto Pulse Control is disabled, the range of the 

PDATA value is 0-1023 

The HW Average control is a pulldown menu that defines the number of ADC samples collected and 

averaged during a cycle. The control can be set to “Disabled” or to 2, 4, 8, or 16 samples. 

4.8.2 Prox Output Data 

The top right corner of the Prox tab displays the output data. This data is continuously read. The 

polling interval is shown above the tab.  

● PDATA displays the Proximity ADC channel data counts  

● StDev displays the calculated standard deviation of the last 32 PDATA samples displayed on 

the screen. 

4.8.3 Prox Data Plot 

The remaining portion of the Prox tab is used to display a running plot of the collected PDATA values. 

The last 350 values are collected and plotted on the graph. As additional values are added, the old 

values will be deleted from the left side of the graph. To start the plotting function, check the Enable 

Plot checkbox.  
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Figure 12:  

Prox Data Plot 

 

 

The scale of the Y-axis of the plot can be adjusted by clicking on the small up and down arrows at the 

top left corner of the plot. The scale can be set to any power of 2 from 16 to 16384. 

Click the Clear Plot button to discard the current data and continue plotting the new data. Note if the 

Clear Plot button is clicked while the plot is disabled, the data is discarded, but the actual plot will not 

be updated until the plot function is re-enabled. 
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5 Resources 

For additional information regarding the TMD2755, please refer to the datasheet. For information 

regarding the installation of the TMD2755 EVM host application software please refer to the TMD2755 

EVM Quick Start Guide. 

Designer’s Notebooks dealing with various aspects of optical measurement and optical measurement 

applications are available. All content is available on the ams website www.ams.com. 

 

 
For further information, please refer to the following documents: 

 

● TMD2755 Datasheet 

● TMD2755 EVM Quick Start Guide (QSG) 

● TMD2755 EVM User’s Guide (this document) 

● TMD2755 EVM Schematic Layout 
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6 Revision Information 

 

Changes from previous version to current revision v2-00 Page 

New range for PLDRIVE control settings 14 

  

  

  

  

  

  

 
● Page and figure numbers for the previous version may differ from page and figure numbers in the current revision. 

● Correction of typographical errors is not explicitly mentioned. 
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7 Legal Information 

Copyrights & Disclaimer 

Copyright ams AG, Tobelbader Strasse 30, 8141 Premstaetten, Austria-Europe. Trademarks Registered. All rights reserved. 
The material herein may not be reproduced, adapted, merged, translated, stored, or used without the prior written consent of the 
copyright owner. 

Demo Kits, Evaluation Kits and Reference Designs are provided to recipient on an “as is” basis for demonstration and 
evaluation purposes only and are not considered to be finished end-products intended and fit for general consumer use, 
commercial applications and applications with special requirements such as but not limited to medical equipment or automotive 
applications. Demo Kits, Evaluation Kits and Reference Designs have not been tested for compliance with electromagnetic 
compatibility (EMC) standards and directives, unless otherwise specified. Demo Kits, Evaluation Kits and Reference Designs 
shall be used by qualified personnel only. 

ams AG reserves the right to change functionality and price of Demo Kits, Evaluation Kits and Reference Designs at any time 
and without notice. 

Any express or implied warranties, including, but not limited to the implied warranties of merchantability and fitness for a 
particular purpose are disclaimed. Any claims and demands and any direct, indirect, incidental, special, exemplary or 
consequential damages arising from the inadequacy of the provided Demo Kits, Evaluation Kits and Reference Designs or 
incurred losses of any kind (e.g. loss of use, data or profits or business interruption however caused) as a consequence of their 
use are excluded. 

ams AG shall not be liable to recipient or any third party for any damages, including but not limited to personal injury, property 
damage, loss of profits, loss of use, interruption of business or indirect, special, incidental or consequential damages, of any 
kind, in connection with or arising out of the furnishing, performance or use of the technical data herein. No obligation or liability 
to recipient or any third party shall arise or flow out of ams AG rendering of technical or other services. 

 

  

RoHS Compliant & ams Green Statement 

RoHS Compliant: The term RoHS compliant means that ams AG products fully comply with current RoHS directives. Our 

semiconductor products do not contain any chemicals for all 6 substance categories plus additional 4 substance categories (per 
amendment EU 2015/863), including the requirement that lead not exceed 0.1% by weight in homogeneous materials. Where 
designed to be soldered at high temperatures, RoHS compliant products are suitable for use in specified lead-free processes.  

ams Green (RoHS compliant and no Sb/Br/Cl): ams Green defines that in addition to RoHS compliance, our products are free 
of Bromine (Br) and Antimony (Sb) based flame retardants (Br or Sb do not exceed 0.1% by weight in homogeneous material) 
and do not contain Chlorine (Cl not exceed 0.1% by weight in homogeneous material). 

Important Information: The information provided in this statement represents ams AG knowledge and belief as of the date that 

it is provided. ams AG bases its knowledge and belief on information provided by third parties, and makes no representation or 
warranty as to the accuracy of such information. Efforts are underway to better integrate information from third parties. ams AG 
has taken and continues to take reasonable steps to provide representative and accurate information but may not have 
conducted destructive testing or chemical analysis on incoming materials and chemicals. ams AG and ams AG suppliers 
consider certain information to be proprietary, and thus CAS numbers and other limited information may not be available for 
release. 

 

  

 

Headquarters 

ams AG 

Tobelbader Strasse 30 

8141 Premstaetten 

Austria, Europe 

Tel: +43 (0) 3136 500 0 

Please visit our website at www.ams.com 

Buy our products or get free samples online at www.ams.com/Products 

Technical Support is available at www.ams.com/Technical-Support 

Provide feedback about this document at www.ams.com/Document-Feedback 

For sales offices, distributors and representatives go to www.ams.com/Contact 

For further information and requests, e-mail us at ams_sales@ams.com 
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