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1. Recommended Documentation 

 
The following Nordic Semiconductor documents and Software Dev Kits are required to understand the 
complete setup and programming methods. 
 
Nordic Semiconductor Documents 
 

 nRF5340 Development kit User Guide, hardware section should be partially ignored – Insight SiP 
development kit hardware replaces Nordic Semiconductor hardware. 

 nRF5340 Product Specification – make sure you have the last document version updated. 
 nRF Connect SDK for software development on nRF53 Series. 

 
To access documentation, information, go to: 
 

 Official Nordic Semi website http://www.nordicsemi.com  
 The Nordic Semiconductor Infocenter is a “comprehensive library” containing technical documentation 

for current and legacy solutions and technologies http://infocenter.nordicsemi.com/index.jsp 
 Find documentation about nRF Connect SDK here 

https://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/index.html 
 Ask any Nordic related question and get help https://devzone.nordicsemi.com/questions 
 For any question, you can also open a case here https://devzone.nordicsemi.com/support/add 

 
Software Dev kits 
 

 nRF Connect SDK which includes Zephyr based source code as well as SES project files. 
 nRF Connect for Desktop. 
 nRF Connect application for Smartphone. 
 nRF Toolbox application for Smartphone.  
 

To access these files, go to www.nordicsemi.com and download the files. Instructions can be found in 
Section 0. 
 
Other Insight SiP documents 
 
To complete the above, following documents are available on Insight SIP website or/and on request: 
 

 AN21100x App Note – this document. 
 BLE module data sheet. 
 BLE Test Board schematic. 
 ISP130603 Interface Board schematic. 

  

http://www.nordicsemi.com/
http://infocenter.nordicsemi.com/index.jsp
https://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/index.html
https://devzone.nordicsemi.com/questions
https://devzone.nordicsemi.com/support/add
http://www.nordicsemi.com/
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2. Hardware Content 

 
2.1. Global Description 
 
The picture below shows the Evaluation Board hardware content for ISP2053-AX modules, integrating 
NFC functionality: 
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2.2. ISP2053-AX Module 
 
ISP2053 module series provides BT 5 connectivity with an embedded antenna. 
 

 
 

The modules are based on Nordic Semiconductor nRF53 series 2.4 GHz wireless SoC. They integrate a  
2.4 GHz transceiver, two Arm® Cortex®-M33 processors, flash memory, and analog and digital 
peripherals. They support Bluetooth low energy and a range of proprietary 2.4 GHz protocols, additional 
protocols like ANT+, Zigbee, Thread and Bluetooth Mesh. 
 
The modules measure 8 x 8 x 1 mm. They integrate all the decoupling capacitors, the 32 MHz and  
32 kHz crystals, their load capacitors, the DC-DC converter component, the RF matching circuit and the 
antenna in addition to the wireless SoC. For more details, please refer to related Insight SiP module data 
sheet. 
 
The module has the following features: 

 Application Processor ARM Cortex M33 1 MB Flash + 512 KB RAM and 8 KB Cache 
 Network Processor ARM Cortex M33 256 KB Flash + 64 KB RAM and 2 KB Cache 
 Security ARM TrustZone & CryptoCell 312 
 Configurable 46 GPIOs including 8 ADCs 
 Digital interfaces USB, QSPI, SPI, UART, I²S, PDM, PWM 
 +3 dBm output power 
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2.3. ISP2053-AX-TB Test Board 
 
Board dimensions are 50 x 37 mm.  
 

 
 
It includes: 
 

 ISP2053-AX BLE module 
 Reset button 
 J1, J2, J3: FPC connectors to connect to the ISP300603 Interface board. 
 J4: JTAG footprint for programming and debug when connected to a Segger J-Link Probe. 
 J5: 2 x 5 pin header for programming and debug when connected to a Nordic Evaluation Board. 
 J6: Header for power supply configuration. 

 

 
 J8: USB female connector 
 J9, J10, J11, J12, J13, J14: 2x5 pin header footprint to access all GPIOs. 
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 Normal/High Voltage mode switch 

 
 
 
About power supply configuration: 
In normal voltage, power can be supplied by: 

 the ISP130603 Interface board through the 10 pin FPC cable. 
 “3V” pin of J6 header, apply between 1.7V and 3.6V. 

In high voltage mode, power can be supplier by: 
 The onboard 5V DCDC converter (Place the jumper on the “DCDC EN” part of J6 header). 
 “5V” pin of J6 header, apply between 2.5V and 5.5V. 
 USB  

 
 
The ISP2053-AX-TB electrical schematic is available from the website. 
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2.4.  ISP130603 Interface Board 
 
ISP130603 is an interface board that has dimensions of 100 x 80 mm. The ISP130603 electrical schematic 
is presented in document SC130603F. 
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3. Software Installation 

 
3.1. PC Software Installation 
 
This paragraph describes the steps to follow for software installation. 
 
1. Download nRF Connect for Desktop. 
 
2. In nRF Connect for Desktop, install the Toolchain manager. 

 
3. In Toolchain manager install the last SDK version. 
 
4. Download and install Realterm from https://realterm.sourceforge.io/index.html#downloads_Download 
 
For more information on SDK installation go to 
http://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/getting_started.html 
 

3.2. Smartphone Software Installation 

 
Download the smartphone application “nRF Connect” and “nRF Toolbox” available on the Play Store 
(Android version) and the App Store (IOS). 
 
Note  

You can also use NRF5 Development Dongle by purchasing it separately from Nordic Semiconductor 
https://www.nordicsemi.com/Software-and-tools/Development-Kits, please refer to the corresponding 
paragraph nRF528xx Kit User Guide document. 
 
 
  

https://www.nordicsemi.com/Products/Development-tools/nrf-connect-for-desktop/download
http://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/getting_started.html
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4. Generic Setup 

 
4.1. Hardware setup 

 
1. Set the test board in “Normal voltage mode” 

 
2. Connect the USB cable from the Interface Board ISP130603 to your computer. 
 
3. Connect the BLE Test Board to the ISP130603 Interface Board with the 10 pin, 14 pin and 22 pin 

FPC jumper cables. 
 

 
 
4.2. Loading using an existing .hex 
 

1. Start nRF Connect for desktop and click Programmer 
 

2. Drag and drop both application core and network core .hex files in the “Files memory layout” box. 
Then program by pressing “Erase & Write”. 
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5. BLE UART Example 

 
5.1. Overview 
 
This paragraph shows how to set up and program an example that emulates a serial port over BLE. In this 
example, the Insight SiP development boards serve as a peer to the phone application  
"nRF Toolbox", which is available for iOS from Apple Store and for Android from Play Store. In addition, 
the example demonstrates how to use a proprietary (vendor-specific) service and characteristics with the 
SoftDevice. In order to use Bluetooth Low Energy and UART interface, the software is loaded in 2 parts. 
 

 
 

5.2. Setup 
 
Connect the test board to the interface ISP130603 board using the 3 FPC cables. 
On the ISP130603 Interface Board, connect with jumpers or wires provided in the kit:  

• RXD to P0_08 

• TXD to P0_06 

• CTS to P0_07 

• RTS to P0_05 
 
5.3. Build and load using SES 
 
By default, the configuration of  the uart pins is not compatible with our interface board. Therefore, we 
need to modify the board configuration file. 
To modify the code, we will use Segger Embedded Studio (SES). 
 

1. Create project 
 
In nRF Connect, Toolchain manager, click on “Open Segger Embedded Studio” 
In SES click File -> Open nRF Connect SDK Project… 
In “Projects” select “peripheral_uart” and in “Board Name” select “nrf5340dk_nrf5340_cpuapp”. Click OK. 
 
 

2. Modify the the uart0 configuration 
 
Create an overlay file by either method: 

➢ Create manually a file called nrf5340dk_nrf5340_cpuapp.overlay in the project directory. 
➢ In SES click Project -> Edit Device Tree then click OK. 

 

 



 

 

 

 

 

 

 
  

November 8, 2021 Page 13/17 Document Ref: isp_ble_AN211001_R0.docx 

Insight SiP  – Green Side – 400  avenue Roumanille  – BP 309 – 06906  Sophia-Antipolis Cedex – France – www.insightsip.com  
The information contained in this document is the property of Insight SiP and should not be disclosed  to  any third party without written permission. 

Specification subject to change without notice.  
 
  

APPLICATION NOTE 
ISP2053 Eval Board 

 

Write in the overlay file: 
&uart0 { 

tx-pin = <6>; 
rx-pin = <8>; 
rts-pin = <5>; 
cts-pin = <7>; 

}; 
 

3. Build the project 
 
Click Project -> Run CMake… and then Click Project -> Build Solution. 
Both application core and network core are now generated. They are in the following directories: 

➢ <SDK>\9ncs\v1.7.0\nrf\samples\bluetooth\peripheral_uart\build_nrf5340dk_nrf5340_cpuapp\zeph
yr for the application core file. 

➢ <SDK>\ncs\v1.7.0\nrf\samples\bluetooth\peripheral_uart\build_nrf5340dk_nrf5340_cpuapp\hci_rp
msg\zephyr for the network core file. 

 
4. Flash the module 

 
Using either of these methods: 

➢ Using nRF Connect / Programmer, see chapter 4.2 
➢ Using SES, you must manually add the network core file to your project. Follow this link to know 

how: https://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/ug_nrf5340.html#using-
segger-embedded-studio 

 
5.4. Test example 
 

1. Setup the smartphone 
 
In the nRF Toolbox application: 

• Click the UART button 

• Click the connect button  

• Select the device: Nordic_UART_Service. 

• Slide the screen from left to right to display the log menu. 
 

2. Setup Computer 
 

Run “RealTerm” on your desktop,configure the baudrate 115200 and choosethe  COM  port  … 
 

 
 

https://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/ug_nrf5340.html%23using-segger-embedded-studio
https://developer.nordicsemi.com/nRF_Connect_SDK/doc/latest/nrf/ug_nrf5340.html%23using-segger-embedded-studio
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5.5. Testing 
 

1. Write some characters and click on “Send ASCII”. 
 

 
 

  
 
 
 
 
 

2. Write some characters on your smartphone and click on send. 
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The communication is established, you are now able to emulate a serial port over BLE. 
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6. NFC Record text Example 

 
6.1. Overview 
 
The Launch App Example shows how to use the NFC tag. It will display a “hello world” on a device that 
supports NFC. 
 
6.2. Building and loading using West 
 

1. Build and flash the sample: 
 
Open nRF Connect, open Toolchain manager and then Open bash 
In the Bash windows, enter the followings commands: 

cd nrf/samples/nfc/record_text 
west build -b nrf5340dk_nrf5340_cpuapp 
west flash 

If the flashing failed, the module might be locked. You may recover using this command: 
west flash --recover 

Note: This sample is running exclusively on the application core. No firmware needs to be flashed on the 
network core. 
 

2. Press the reset button (or power cycle the board) 
 
6.3. Testing 
 
Approach your smartphone to the NFC antenna and a observe a “hello world” display on the screen. 
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7. Direct Test Mode  

 
7.1. Overview 
 
The Direct Test Mode is used during certification and test, Output power and receive sensitivity can be 

measured using this mode. This paragraph shows you how to set up and program the Direct Test Mode 

sample on a test board. 

 
7.2. Setup 
 
Connect the test board to the interface ISP130603 board using the 3 FPC cables. 
On the ISP130603 Interface Board, connect with jumpers or wires provided in the kit:  

• RXD to P0_08 

• TXD to P0_06 
 
7.3. Building and loading using West 
 

1. Modify uart0 pin configuration 
 
Using a text editor open the nrf5340dk_nrf5340_cpunet.overlay file located in 
<SDK>\ncs\v1.x.x\nrf\samples\bluetooth\direct_test_mode\boards. 
Modify the uart0 configuration, it should look like this: 

&uart0 { 
status = "okay"; 
current-speed = <19200>; 
tx-pin = <6>; 
rx-pin = <8>; 

}; 
 

2. Build and flash the sample 
 
Open nRF Connect, open Toolchain manager and then Open bash 
In the Bash windows, enter the followings commands: 

cd nrf/samples/bluetooth/direct_test_mode 
west build -b nrf5340dk_nrf5340_cpunet 
west flash 

Note: The direct test mode is running exclusively on the network core. The tool “west” will automatically 
build “empty_app_core” and flash it to the application core. The “empty_app_core” sample is necessary 
for the network core to boot up. 
 

3. Press the reset button (or power cycle the board)  
 
7.4. Testing 
 

1. Open Direct Test Mode in nRF Connect.  
2. Select device and start Test. 

 


